CVE-2007-3477

NameCVE-2007-3477
DescriptionThe (a) imagearc and (b) imagefilledarc functions in GD Graphics Library (libgd) before 2.0.35 allow attackers to cause a denial of service (CPU consumption) via a large (1) start or (2) end angle degree value.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1613-1
NVD severitymedium (attack range: remote)
Debian Bugs601525
Debian/oldoldstablepackage libwmf is vulnerable; however, the security impact is unimportant.
Debian/oldstablepackage libwmf is vulnerable; however, the security impact is unimportant.
Debian/stablepackage libwmf is vulnerable; however, the security impact is unimportant.
Debian/testingpackage libwmf is vulnerable; however, the security impact is unimportant.
Debian/unstablepackage libwmf is vulnerable; however, the security impact is unimportant.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)squeeze2.0.36~rc1~dfsg-5fixed
squeeze (lts)2.0.36~rc1~dfsg-5+deb6u1fixed
wheezy2.0.36~rc1~dfsg-6.1fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u1fixed
stretch, jessie2.1.0-5fixed
sid2.1.1-1fixed
libwmf (PTS)squeeze0.2.8.4-6.1vulnerable
stretch, jessie, wheezy, sid0.2.8.4-10.3vulnerable
racket (PTS)wheezy5.2.1+g6~92c8784+dfsg2-2+deb7u1fixed
stretch, jessie6.1-4fixed
sid6.1.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.0.35.dfsg-1low
libgd2sourceetch2.0.33-5.2etch1mediumDSA-1613-1
libwmfsource(unstable)(unfixed)unimportant
racketsource(unstable)5.0.2-1unimportant601525

Notes

Only present in one of the sample pl-scheme packages (plot)
CPU consumption DoS

Search for package or bug name: Reporting problems