CVE-2007-3735

NameCVE-2007-3735
DescriptionMultiple unspecified vulnerabilities in the JavaScript engine in Mozilla Firefox before 2.0.0.5 and Thunderbird before 2.0.0.5 allow remote attackers to cause a denial of service (crash) via unspecified vectors that trigger memory corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1337-1, DSA-1338-1, DSA-1339-1, DSA-1391-1, DTSA-45-1, DTSA-47-1, DTSA-51-1, DTSA-71-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:45.1.0-1~deb7u1fixed
jessie38.8.0-1~deb8u1fixed
jessie (security)1:45.1.0-1~deb8u1fixed
stretch1:45.1.0-1fixed
sid1:45.2.0-1fixed
iceweasel (PTS)wheezy (security), wheezy38.8.0esr-1~deb7u1fixed
jessie (security), jessie38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.3-1high
iceapesourceetch1.0.10~pre070720-0etch1highDSA-1339-1
iceapesourcelenny1.0.10~pre070720-0etch1+lenny1highDTSA-47-1
icedovesource(unstable)2.0.0.6-1low
icedovesourceetch1.5.0.13+1.5.0.14b.dfsg1-0etch1highDSA-1391-1
icedovesourcelenny1.5.0.13+1.5.0.14b.dfsg1-0lenny1highDTSA-71-1
iceweaselsource(unstable)2.0.0.5-1high
iceweaselsourceetch2.0.0.5-0etch1highDSA-1338-1
iceweaselsourcelenny2.0.0.5-0etch1+lenny1highDTSA-45-1
xulrunnersource(unstable)1.8.1.5-1high
xulrunnersourceetch1.8.0.13~pre070720-0etch1highDSA-1337-1
xulrunnersourcelenny1.8.0.13~pre070720-0etch3+lenny1highDTSA-51-1

Notes

Affects only broken setups, enabling js in Icedove is strongly not recommended
MFSA2007-18

Search for package or bug name: Reporting problems