CVE-2007-3736

NameCVE-2007-3736
DescriptionCross-site scripting (XSS) vulnerability in Mozilla Firefox before 2.0.0.5 allows remote attackers to inject arbitrary web script "into another site's context" via a "timing issue" involving the (1) addEventListener or (2) setTimeout function, probably by setting events that activate after the context has changed.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1337-1, DSA-1338-1, DSA-1339-1, DTSA-45-1, DTSA-47-1, DTSA-51-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)38.2.1esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
stretch, jessie (security)38.2.1esr-1~deb8u1fixed
sid38.2.1esr-1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.3-1high
iceapesourceetch1.0.10~pre070720-0etch1mediumDSA-1339-1
iceapesourcelenny1.0.10~pre070720-0etch1+lenny1mediumDTSA-47-1
iceweaselsource(unstable)2.0.0.5-1high
iceweaselsourceetch2.0.0.5-0etch1mediumDSA-1338-1
iceweaselsourcelenny2.0.0.5-0etch1+lenny1mediumDTSA-45-1
xulrunnersource(unstable)1.8.1.5-1high
xulrunnersourceetch1.8.0.13~pre070720-0etch1mediumDSA-1337-1
xulrunnersourcelenny1.8.0.13~pre070720-0etch3+lenny1mediumDTSA-51-1

Notes

MFSA2007-19

Search for package or bug name: Reporting problems