CVE-2007-3738

NameCVE-2007-3738
DescriptionMultiple unspecified vulnerabilities in Mozilla Firefox before 2.0.0.5 allow remote attackers to execute arbitrary code via a crafted XPCNativeWrapper.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1337-1, DSA-1338-1, DSA-1339-1, DSA-1534-2, DTSA-45-1, DTSA-47-1, DTSA-51-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.8.0esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)31.8.0esr-1~deb8u1fixed
stretch, sid38.1.0esr-3fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.3-1medium
iceapesourceetch1.0.13~pre080323b-0etch2highDSA-1534-2
iceapesourcelenny1.0.10~pre070720-0etch1+lenny1highDTSA-47-1
iceweaselsource(unstable)2.0.0.5-1medium
iceweaselsourceetch2.0.0.5-0etch1highDSA-1338-1
iceweaselsourcelenny2.0.0.5-0etch1+lenny1highDTSA-45-1
xulrunnersource(unstable)1.8.1.5-1medium
xulrunnersourceetch1.8.0.13~pre070720-0etch1highDSA-1337-1
xulrunnersourcelenny1.8.0.13~pre070720-0etch3+lenny1highDTSA-51-1

Notes

MFSA2007-25

Search for package or bug name: Reporting problems