CVE-2007-3920

NameCVE-2007-3920
DescriptionGNOME screensaver 2.20 in Ubuntu 7.10, when used with Compiz, does not properly reserve input focus, which allows attackers with physical access to take control of the session after entering an Alt-Tab sequence, a related issue to CVE-2007-3069.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-75-1
NVD severitymedium
Debian Bugs449108

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnome-screensaver (PTS)stretch3.6.1-7fixed
buster3.6.1-10fixed
bullseye, sid3.6.1-13fixed
xorg-server (PTS)stretch2:1.19.2-1+deb9u5fixed
stretch (security)2:1.19.2-1+deb9u4fixed
buster2:1.20.4-1fixed
bullseye, sid2:1.20.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnome-screensaversource(unstable)2.20.0-1.1
gnome-screensaversourceetch(not affected)
gnome-screensaversourcelenny2.18.2-1+lenny1DTSA-75-1
xorg-serversource(unstable)2:1.4.1~git20080118-1medium449108
xorg-serversourceetch(not affected)

Notes

[etch] - gnome-screensaver <not-affected> (Affected Compiz not present in Etch version)
[etch] - xorg-server <not-affected> (Affected Compiz not present in Etch version)

Search for package or bug name: Reporting problems