CVE-2007-3996

NameCVE-2007-3996
DescriptionMultiple integer overflows in libgd in PHP before 5.2.4 allow remote ...
SourceCVE (at NVD; oss-sec, OSVDB, EDB, Red Hat, Ubuntu, Gentoo, SuSE, more)
ReferencesDSA-1613-1
Debian Bugs443456, 601525
Debian/oldstablepackage libwmf is vulnerable; however, the security impact is unimportant.
Debian/stablepackage libwmf is vulnerable; however, the security impact is unimportant.
Debian/testingpackage libwmf is vulnerable; however, the security impact is unimportant.
Debian/unstablepackage libwmf is vulnerable; however, the security impact is unimportant.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)squeeze2.0.36~rc1~dfsg-5fixed
wheezy2.0.36~rc1~dfsg-6.1fixed
jessie, sid2.1.0-3fixed
libwmf (PTS)squeeze0.2.8.4-6.1vulnerable
jessie, wheezy, sid0.2.8.4-10.3vulnerable
racket (PTS)wheezy5.2.1+g6~92c8784+dfsg2-2+deb7u1fixed
jessie, sid5.3.6+dfsg1-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.0.35.dfsg-1medium443456
libgd2sourceetch2.0.33-5.2etch1DSA-1613-1
libwmfsource(unstable)(unfixed)unimportant
racketsource(unstable)5.0.2-1unimportant601525

Notes

Only present in one of the sample pl-scheme packages (plot)
Debian's PHP packages are linked dynamically against libgd
see http://www.php.net/releases/5_2_4.php

Search for package or bug name: Reporting problems

Home - Testing Security Team - Debian Security - Source (SVN)