CVE-2007-4029

NameCVE-2007-4029
Descriptionlibvorbis 1.1.2, and possibly other versions before 1.2.0, allows context-dependent attackers to cause a denial of service via (1) an invalid mapping type, which triggers an out-of-bounds read in the vorbis_info_clear function in info.c, and (2) invalid blocksize values that trigger a segmentation fault in the read function in block.c.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1471-1
NVD severitymedium (attack range: remote)
Debian Bugs437916, 669196
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvorbis (PTS)squeeze (security), squeeze1.3.1-1+squeeze1fixed
wheezy1.3.2-1.3fixed
jessie, sid1.3.4-2fixed
libvorbisidec (PTS)squeeze1.0.2+svn16259-2fixed
jessie, sid, wheezy1.0.2+svn18153-0.2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvorbissource(unstable)1.2.0.dfsg-1medium437916
libvorbissourceetch1.1.2.dfsg-1.3mediumDSA-1471-1
libvorbissourcesarge1.1.0-2mediumDSA-1471-1
libvorbisidecsource(unstable)1.0.2+svn16259-2medium669196

Notes

svn revisions fixing this https://bugzilla.redhat.com/show_bug.cgi?id=249780

Search for package or bug name: Reporting problems