CVE-2007-4066

NameCVE-2007-4066
DescriptionMultiple buffer overflows in Xiph.Org libvorbis before 1.2.0 allow context-dependent attackers to cause a denial of service or have other unspecified impact via a crafted OGG file, aka trac Changesets 13162, 13168, 13169, 13170, 13172, 13211, and 13215, as demonstrated by an overflow in oggenc.exe related to the _psy_noiseguards_8 array.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1471-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs669196
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvorbis (PTS)squeeze (security), squeeze1.3.1-1+squeeze1fixed
wheezy1.3.2-1.3fixed
jessie, sid1.3.4-2fixed
libvorbisidec (PTS)squeeze1.0.2+svn16259-2fixed
jessie, sid, wheezy1.0.2+svn18153-0.2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvorbissource(unstable)1.2.0.dfsg-1medium
libvorbissourceetch1.1.2.dfsg-1.3mediumDSA-1471-1
libvorbissourcesarge1.1.0-2mediumDSA-1471-1
libvorbisidecsource(unstable)1.0.2+svn16259-2medium669196

Notes

svn revisionsions fixing this: https://bugzilla.redhat.com/show_bug.cgi?id=249780

Search for package or bug name: Reporting problems