CVE-2007-4321

NameCVE-2007-4321
Descriptionfail2ban 0.8 and earlier does not properly parse sshd log files, which allows remote attackers to add arbitrary hosts to the /etc/hosts.deny file and cause a denial of service by adding arbitrary IP addresses to the sshd log file, as demonstrated by logging in via ssh with a client protocol version identification containing an IP address string, a different vector than CVE-2006-6302.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1456-1
NVD severitymedium (attack range: remote)
Debian Bugs438187

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fail2ban (PTS)wheezy, wheezy (security)0.8.6-3wheezy3fixed
jessie0.8.13-1fixed
stretch0.9.6-2fixed
buster, sid0.9.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fail2bansource(unstable)0.8.0-4medium438187
fail2bansourceetch0.7.5-2etch1mediumDSA-1456-1

Search for package or bug name: Reporting problems