CVE-2007-4352

NameCVE-2007-4352
DescriptionArray index error in the DCTStream::readProgressiveDataUnit method in xpdf/Stream.cc in Xpdf 3.02pl1, as used in poppler, teTeX, KDE, KOffice, CUPS, and other products, allows remote attackers to trigger memory corruption and execute arbitrary code via a crafted PDF file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1480-1, DSA-1509-1, DSA-1537-1, DTSA-85-1, DTSA-86-1
NVD severityhigh (attack range: remote, user-initiated)
Debian Bugs450628, 450629, 450630, 450631
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)squeeze1.4.4-7+squeeze5fixed
squeeze (security)1.4.4-7+squeeze4fixed
squeeze (lts)1.4.4-7+squeeze9fixed
wheezy1.5.3-5+deb7u4fixed
wheezy (security)1.5.3-5+deb7u6fixed
jessie1.7.5-11fixed
jessie (security)1.7.5-11+deb8u1fixed
stretch, sid2.0.3-10fixed
kdegraphics (PTS)squeeze4:4.4.5-2fixed
koffice (PTS)squeeze1:2.2.1-4fixed
libextractor (PTS)squeeze1:0.5.23+dfsg-7fixed
wheezy1:0.6.3-5fixed
stretch, sid, jessie1:1.3-2fixed
poppler (PTS)squeeze, squeeze (security)0.12.4-1.2+squeeze3fixed
squeeze (lts)0.12.4-1.2+squeeze4fixed
wheezy0.18.4-6fixed
jessie0.26.5-2fixed
stretch, sid0.26.5-3fixed
swftools (PTS)wheezy0.9.2+ds1-3fixed
stretch, sid, jessie0.9.2+git20130725-2fixed
xpdf (PTS)squeeze3.02-12+squeeze1fixed
wheezy3.03-10fixed
stretch, sid, jessie3.03-17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)1.1.22-7high
cupsyssource(unstable)1.1.22-7high
gpdfsource(unstable)(unfixed)high
kdegraphicssource(unstable)4:3.5.8-2medium450630
kdegraphicssourceetch(not affected)
kdegraphicssourcelenny4:3.5.7-4+lenny1highDTSA-85-1
kofficesource(unstable)1:1.6.3-4medium450631
kofficesourceetch1:1.6.1-2etch2highDSA-1509-1
kofficesourcelenny1:1.6.3-3+lenny1highDTSA-86-1
libextractorsource(unstable)0.5.12-1high
pdftohtmlsource(unstable)(unfixed)high
pdftohtmlsourceetch0.36-13etch1high
popplersource(unstable)0.6.2-1medium450628
popplersourceetch0.4.5-5.1etch2highDSA-1480-1
swftoolssource(unstable)0.9.2+ds1-2high
tetex-binsource(unstable)3.0-12high
xpdfsource(unstable)3.02-1.3medium450629
xpdfsourceetch3.01-9.1+etch2highDSA-1537-1

Notes

[etch] - kdegraphics <not-affected> (Vulnerable code not used)
pdftex links to poppler since 3.0-12, thus marking as fixed
cups uses xpdf-utils and poppler-utils since version 1.1.22-7
libextractor uses internal pdf decoder since 0.5.12-1, thus marking as fixed

Search for package or bug name: Reporting problems