CVE-2007-5338

NameCVE-2007-5338
DescriptionMozilla Firefox before 2.0.0.8 and SeaMonkey before 1.1.5 allow remote attackers to execute arbitrary Javascript with user privileges by using the Script object to modify XPCNativeWrappers in a way that causes the script to be executed when a chrome action is performed.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1392-1, DSA-1396-1, DSA-1401-1, DSA-1534-2, DTSA-69-1, DTSA-80-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.7.0esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)31.7.0esr-1~deb8u1fixed
stretch, sid38.0.1-1fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.5high
iceapesourceetch1.0.13~pre080323b-0etch2highDSA-1534-2
iceapesourcelenny1.0.11~pre071022-0etch1+lenny1highDTSA-80-1
iceweaselsource(unstable)2.0.0.8-1high
iceweaselsourceetch2.0.0.6+2.0.0.8-0etch1highDSA-1396-1
xulrunnersource(unstable)1.8.1.9-1high
xulrunnersourceetch1.8.0.14~pre071019b-0etch1highDSA-1392-1
xulrunnersourcelenny1.8.0.14~pre071019b-0lenny1highDTSA-69-1

Notes

MFSA2007-35

Search for package or bug name: Reporting problems