CVE-2007-5959

NameCVE-2007-5959
DescriptionMultiple unspecified vulnerabilities in Mozilla Firefox before 2.0.0.10 and SeaMonkey before 1.1.7 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger memory corruption.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1424-1, DSA-1425-1, DSA-1506-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)38.2.1esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)38.2.1esr-1~deb8u1fixed
stretch38.2.0esr-1~stretchfixed
sid38.2.1esr-1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.7-1high
iceapesourceetch1.0.12~pre080131b-0etch1highDSA-1506-1
iceweaselsource(unstable)2.0.0.10-1high
iceweaselsourceetch2.0.0.10-0etch1highDSA-1424-1
xulrunnersource(unstable)1.8.1.11-1high
xulrunnersourceetch1.8.0.14~pre071019c-0etch1highDSA-1425-1

Notes

MFSA2007-38

Search for package or bug name: Reporting problems