CVE-2007-6112

NameCVE-2007-6112
DescriptionBuffer overflow in the PPP dissector Wireshark (formerly Ethereal) 0.99.6 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-92-1
NVD severityhigh
Debian Bugs452381

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u14fixed
jessie (security)1.12.1+g01b65bf-4+deb8u19fixed
stretch (security), stretch2.6.7-1~deb9u1fixed
buster2.6.8-1.1fixed
bullseye, sid3.0.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
etherealsourcesarge(not affected)
wiresharksource(unstable)0.99.7~pre1-1medium452381
wiresharksourceetch(not affected)
wiresharksourcelenny0.99.6rel-5+0.99.7~pre1-1+lenny1DTSA-92-1

Notes

[etch] - wireshark <not-affected> (Vulnerable code not present)
[sarge] - ethereal <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems