CVE-2008-0008

NameCVE-2008-0008
DescriptionThe pa_drop_root function in PulseAudio 0.9.8, and a certain 0.9.9 build, does not check return values from (1) setresuid, (2) setreuid, (3) setuid, and (4) seteuid calls when attempting to drop privileges, which might allow local users to gain privileges by causing those calls to fail via attacks such as resource exhaustion.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1476-1
NVD severityhigh (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pulseaudio (PTS)squeeze0.9.21-3+squeeze1fixed
wheezy2.0-6.1fixed
jessie5.0-13fixed
stretch6.0-2fixed
sid6.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pulseaudiosource(unstable)0.9.9-1high
pulseaudiosourceetch0.9.5-5etch1highDSA-1476-1

Search for package or bug name: Reporting problems