CVE-2008-0411

NameCVE-2008-0411
DescriptionStack-based buffer overflow in the zseticcspace function in zicc.c in Ghostscript 8.61 and earlier allows remote attackers to execute arbitrary code via a postscript (.ps) file containing a long Range array in a .seticcspace operator.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1510-1
NVD severitymedium (attack range: remote)
Debian Bugs468190

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)wheezy9.05~dfsg-6.3+deb7u2fixed
wheezy (security)9.05~dfsg-6.3+deb7u7fixed
jessie9.06~dfsg-2+deb8u5fixed
jessie (security)9.06~dfsg-2+deb8u6fixed
stretch (security), stretch9.20~dfsg-3.2+deb9u1fixed
buster, sid9.22~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)8.61.dfsg.1-1.1medium468190
gs-espsourceetch8.15.3.dfsg.1-1etch1mediumDSA-1510-1
gs-espsourcesarge7.07.1-9sarge1mediumDSA-1510-1
gs-gplsource(unstable)(unfixed)medium
gs-gplsourceetch8.54.dfsg.1-5etch1mediumDSA-1510-1
gs-gplsourcesarge8.01-6mediumDSA-1510-1

Search for package or bug name: Reporting problems