CVE-2008-1036

NameCVE-2008-1036
DescriptionThe International Components for Unicode (ICU) library in Apple Mac OS X before 10.5.3, Red Hat Enterprise Linux 5, and other operating systems omits some invalid character sequences during conversion of some character encodings, which might allow remote attackers to conduct cross-site scripting (XSS) attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1762-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icu (PTS)wheezy4.8.1.1-12+deb7u3fixed
wheezy (security)4.8.1.1-12+deb7u7fixed
jessie (security), jessie52.1-8+deb8u5fixed
stretch57.1-6fixed
buster, sid57.1-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icusource(unstable)4.0.1-1medium
icusourceetch3.6-2etch2mediumDSA-1762-1
icusourcelenny3.8.1-3+lenny1mediumDSA-1762-1

Search for package or bug name: Reporting problems