Information on source package icu

Available versions

ReleaseVersion
wheezy4.8.1.1-12+deb7u3
wheezy (security)4.8.1.1-12+deb7u6
jessie52.1-8+deb8u4
jessie (security)52.1-8+deb8u5
stretch57.1-6
sid57.1-6

Open issues

BugwheezyjessiestretchsidDescription
CVE-2017-7868vulnerablefixedfixedfixedInternational Components for Unicode (ICU) for C/C++ before 2017-02-13 ...
CVE-2017-7867vulnerablefixedfixedfixedInternational Components for Unicode (ICU) for C/C++ before 2017-02-13 ...

Resolved issues

BugDescription
TEMP-0780503-1359A5Incomplete fix for CVE-2014-7940
TEMP-0778511-AAAFE7more to CVE-2014-6585
CVE-2016-7415Stack-based buffer overflow in the Locale class in common/locid.cpp in ...
CVE-2016-6293The uloc_acceptLanguageFromHTTP function in common/uloc.cpp in ...
CVE-2016-0494Unspecified vulnerability in the Java SE and Java SE Embedded ...
CVE-2015-4844Unspecified vulnerability in Oracle Java SE 6u101, 7u85, and 8u60, and ...
CVE-2015-4760Unspecified vulnerability in Oracle Java SE 6u95, 7u80, and 8u45 ...
CVE-2015-2632Unspecified vulnerability in Oracle Java SE 6u95, 7u80, and 8u45 ...
CVE-2015-1270The ucnv_io_getConverterName function in common/ucnv_io.cpp in ...
CVE-2014-9911Stack-based buffer overflow in the ures_getByKeyWithFallback function ...
CVE-2014-9654The Regular Expressions package in International Components for ...
CVE-2014-8147The resolveImplicitLevels function in common/ubidi.c in the Unicode ...
CVE-2014-8146The resolveImplicitLevels function in common/ubidi.c in the Unicode ...
CVE-2014-7940The collator implementation in i18n/ucol.cpp in International ...
CVE-2014-7926The Regular Expressions package in International Components for ...
CVE-2014-7923The Regular Expressions package in International Components for ...
CVE-2014-6591Unspecified vulnerability in the Java SE component in Oracle Java SE ...
CVE-2014-6585Unspecified vulnerability in Oracle Java SE 5.0u75, 6u85, 7u72, and ...
CVE-2013-2924Use-after-free vulnerability in International Components for Unicode ...
CVE-2013-2419Unspecified vulnerability in the Java Runtime Environment (JRE) ...
CVE-2013-2384Unspecified vulnerability in the Java Runtime Environment (JRE) ...
CVE-2013-2383Unspecified vulnerability in the Java Runtime Environment (JRE) ...
CVE-2013-1569Unspecified vulnerability in the Java Runtime Environment (JRE) ...
CVE-2013-0900Race condition in the International Components for Unicode (ICU) ...
CVE-2011-4599Stack-based buffer overflow in the _canonicalize function in ...
CVE-2009-0153International Components for Unicode (ICU) 4.0, 3.6, and other 3.x ...
CVE-2008-1036The International Components for Unicode (ICU) library in Apple Mac OS ...
CVE-2007-4771Heap-based buffer overflow in the doInterval function in regexcmp.cpp ...
CVE-2007-4770libicu in International Components for Unicode (ICU) 3.8.1 and earlier ...

Security announcements

DSA / DLADescription
DSA-3830-1icu - security update
DLA-744-1icu - security update
DSA-3725-1icu - security update
DLA-615-1icu - security update
DLA-545-1icu - security update
DLA-381-1icu - security update
DSA-3360-1icu - security update
DSA-3323-1icu - security update
DSA-3323-1icu - security update
DLA-283-1icu - security update
DLA-219-1icu - security update
DSA-3187-1icu - security update
DSA-2786-1icu - several
DSA-2786-1icu - several
DSA-2397-1icu - buffer underflow
DSA-2397-1icu - buffer underflow
DSA-1889-1icu - programming error
DSA-1889-1icu - programming error
DSA-1762-1icu - cross site scripting
DSA-1762-1icu - cross site scripting
DSA-1511-1icu - multiple problems

Search for package or bug name: Reporting problems