CVE-2008-1419

NameCVE-2008-1419
DescriptionXiph.org libvorbis 1.2.0 and earlier does not properly handle a zero value for codebook.dim, which allows remote attackers to cause a denial of service (crash or infinite loop) or trigger an integer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1591-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs482518, 669196
Debian/oldoldstablepackage libvorbisidec is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvorbis (PTS)squeeze, squeeze (security)1.3.1-1+squeeze1fixed
wheezy1.3.2-1.3fixed
stretch, sid, jessie1.3.4-2fixed
libvorbisidec (PTS)squeeze1.0.2+svn16259-2vulnerable
stretch, sid, jessie, wheezy1.0.2+svn18153-0.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvorbissource(unstable)1.2.0.dfsg-3.1medium482518
libvorbissourceetch1.1.2.dfsg-1.4mediumDSA-1591-1
libvorbisidecsource(unstable)1.0.2+svn18153-0.1medium669196

Notes

[squeeze] - libvorbisidec <no-dsa> (Minor issue, no dev-deps)

Search for package or bug name: Reporting problems