CVE-2008-1628

NameCVE-2008-1628
DescriptionStack-based buffer overflow in the audit_log_user_command function in lib/audit_logging.c in Linux Audit before 1.7 might allow remote attackers to execute arbitrary code via a long command argument. NOTE: some of these details are obtained from third party information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-123-1
NVD severitymedium (attack range: local)
Debian Bugs475227

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
audit (PTS)jessie1:2.4-1fixed
stretch1:2.6.7-2fixed
buster, sid1:2.8.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
auditsource(unstable)1.5.3-2.1medium475227
auditsourcelenny1.5.3-2+lenny1mediumDTSA-123-1

Notes

auditd runs as root

Search for package or bug name: Reporting problems