CVE-2008-2009

NameCVE-2008-2009
DescriptionXiph.org libvorbis before 1.0 does not properly check for underpopulated Huffman trees, which allows remote attackers to cause a denial of service (crash) via a crafted OGG file that triggers memory corruption during execution of the _make_decode_tree function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs482039, 669196

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvorbis (PTS)stretch1.3.5-4+deb9u2fixed
stretch (security)1.3.5-4+deb9u3fixed
buster1.3.6-2fixed
bookworm, sid, bullseye1.3.7-1fixed
libvorbisidec (PTS)stretch (security), stretch1.0.2+svn18153-1+deb9u1fixed
buster1.2.1+git20180316-3fixed
bookworm, sid, bullseye1.2.1+git20180316-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvorbissourceetch(not affected)
libvorbissourcelenny(not affected)
libvorbissource(unstable)1.2.0.dfsg-4482039
libvorbisidecsource(unstable)1.0.2+svn18153-0.1669196

Notes

[squeeze] - libvorbisidec <no-dsa> (Minor issue, no dev-deps)
[etch] - libvorbis <not-affected> (actual vulnerability fixed pre-1.0)
[lenny] - libvorbis <not-affected> (actual vulnerability fixed pre-1.0)
additional hardening features have already been added to the unstable
packages that would be useful to have in stable, so proposing as spu/ospu

Search for package or bug name: Reporting problems