CVE-2008-2149

NameCVE-2008-2149
DescriptionStack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1634-1
NVD severityhigh (attack range: remote)
Debian Bugs481186

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordnet (PTS)wheezy1:3.0-29fixed
buster, sid, jessie, stretch1:3.0-33fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordnetsource(unstable)1:3.0-10high481186
wordnetsourceetch1:2.1-4+etch1highDSA-1634-1

Notes

wordnet can be used as a backend to web applications

Search for package or bug name: Reporting problems