CVE-2008-2266

NameCVE-2008-2266
Descriptionuulib/uunconc.c in UUDeview 0.5.20, as used in nzbget before 0.3.0 and possibly other products, allows local users to overwrite arbitrary files via a symlink attack on a temporary filename generated by the tempnam function. NOTE: this may be a CVE-2004-2265 regression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs480972

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libconvert-uulib-perl (PTS)jessie, stretch1:1.4~dfsg-1fixed
bullseye, sid, buster1:1.5~dfsg-1fixed
pan (PTS)jessie0.139-3fixed
stretch0.141-2fixed
buster0.145-1fixed
bullseye, sid0.146-1fixed
uudeview (PTS)jessie0.5.20-3.4fixed
stretch0.5.20-9fixed
buster0.5.20-11fixed
bullseye, sid0.5.20-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libconvert-uulib-perlsource(unstable)(not affected)
pansource(unstable)(not affected)
uudeviewsource(unstable)0.5.20-3.1low480972

Notes

[etch] - uudeview <no-dsa> (Minor issue)
- libconvert-uulib-perl <not-affected> (Code patched by libconver-uulib upstream to use mkstemp)
- pan <not-affected> (Code patched to use g_mkstemp)
See CVE-2004-2265, where the problem occured as well

Search for package or bug name: Reporting problems