CVE-2008-2380

NameCVE-2008-2380
DescriptionSQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1688-1, DTSA-180-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
courier-authlib (PTS)squeeze0.63.0-3fixed
wheezy0.63.0-6fixed
jessie, sid0.66.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
courier-authlibsource(unstable)0.61.0-1+lenny1medium
courier-authlibsourceetch0.58-4+etch2mediumDSA-1688-1
courier-authlibsourcelenny0.61.0-1+lenny1mediumDTSA-180-1

Search for package or bug name: Reporting problems