CVE-2008-2667

NameCVE-2008-2667
DescriptionSQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0.60.6 on SUSE openSUSE 10.3 and 11.0, and other platforms, when MySQL and a non-Latin character set are used, allows remote attackers to execute arbitrary SQL commands via the username and unspecified other vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1688-1
NVD severitymedium (attack range: remote)
Debian Bugs485424
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
courier-authlib (PTS)squeeze0.63.0-3fixed
wheezy0.63.0-6fixed
jessie, sid0.66.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
courier-authlibsource(unstable)0.60.1-2.1medium485424
courier-authlibsourceetch0.58-4+etch2mediumDSA-1688-1

Search for package or bug name: Reporting problems