CVE-2008-2726

NameCVE-2008-2726
DescriptionInteger overflow in the (1) rb_ary_splice function in Ruby 1.8.4 and earlier, 1.8.5 before 1.8.5-p231, 1.8.6 before 1.8.6-p230, 1.8.7 before 1.8.7-p22, and 1.9.0 before 1.9.0-2; and (2) the rb_ary_replace function in 1.6.x allows context-dependent attackers to trigger memory corruption, aka the "beg + rlen" issue. NOTE: as of 20080624, there has been inconsistent usage of multiple CVE identifiers related to Ruby. The CVE description should be regarded as authoritative, although it is likely to change.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1612-1, DSA-1618-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)squeeze, squeeze (security)1.8.7.302-2squeeze2fixed
squeeze (lts)1.8.7.302-2squeeze4fixed
wheezy1.8.7.358-7.1+deb7u1fixed
wheezy (security)1.8.7.358-7.1+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)1.8.7.22-1high
ruby1.8sourceetch1.8.5-4etch2highDSA-1612-1
ruby1.9source(unstable)1.9.0.2-1high
ruby1.9sourceetch1.9.0+20060609-1etch2highDSA-1618-1

Search for package or bug name: Reporting problems