CVE-2008-2802

NameCVE-2008-2802
DescriptionMozilla Firefox before 2.0.0.15, Thunderbird 2.0.0.14 and earlier, and SeaMonkey before 1.1.10 allow remote attackers to execute arbitrary code via an XUL document that includes a script from a chrome: URI that points to a fastload file, related to this file's "privilege level."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1607-1, DSA-1615-1, DSA-1621-1, DSA-1697-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:45.2.0-2~deb7u1fixed
jessie38.8.0-1~deb8u1fixed
jessie (security)1:45.2.0-1~deb8u1fixed
stretch, sid1:45.2.0-4fixed
iceweasel (PTS)wheezy (security), wheezy38.8.0esr-1~deb7u1fixed
jessie (security), jessie38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.10-1high
iceapesourceetch1.0.13~pre080614i-0etch1highDSA-1697-1
icedovesource(unstable)2.0.0.16-1high
icedovesourceetch1.5.0.13+1.5.0.15b.dfsg1+prepatch080614d-0etch1highDSA-1621-1
iceweaselsource(unstable)3.0~b2-1high
iceweaselsourceetch2.0.0.15-0etch1highDSA-1607-1
xulrunnersource(unstable)1.9.0.1-1high
xulrunnersourceetch1.8.0.15~pre080614d-0etch1highDSA-1615-1

Search for package or bug name: Reporting problems