CVE-2008-2803

NameCVE-2008-2803
DescriptionThe mozIJSSubScriptLoader.LoadScript function in Mozilla Firefox before 2.0.0.15, Thunderbird 2.0.0.14 and earlier, and SeaMonkey before 1.1.10 does not apply XPCNativeWrappers to scripts loaded from (1) file: URIs, (2) data: URIs, or (3) certain non-canonical chrome: URIs, which allows remote attackers to execute arbitrary code via vectors involving third-party add-ons.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1607-1, DSA-1615-1, DSA-1621-1, DSA-1697-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
icedove (PTS)squeeze (security), squeeze3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.6.0-1~deb7u1fixed
sid, jessie31.6.0-1fixed
iceweasel (PTS)squeeze (security), squeeze3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.6.0esr-1~deb7u1fixed
sid, jessie31.6.0esr-1fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.10-1medium
iceapesourceetch1.0.13~pre080614i-0etch1mediumDSA-1697-1
icedovesource(unstable)2.0.0.16-1medium
icedovesourceetch1.5.0.13+1.5.0.15b.dfsg1+prepatch080614d-0etch1mediumDSA-1621-1
iceweaselsource(unstable)3.0~b2-1medium
iceweaselsourceetch2.0.0.15-0etch1mediumDSA-1607-1
xulrunnersource(unstable)1.9.0.1-1medium
xulrunnersourceetch1.8.0.15~pre080614d-0etch1mediumDSA-1615-1

Search for package or bug name: Reporting problems