CVE-2008-3577

NameCVE-2008-3577
DescriptionBuffer overflow in src/openttd.cpp in OpenTTD before 0.6.2 allows local users to execute arbitrary code via a large filename supplied to the "-g" parameter in the ttd_main function. NOTE: it is unlikely that this issue would cross privilege boundaries in typical environments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openttd (PTS)buster1.8.0-2fixed
bullseye1.10.3-1fixed
bookworm13.0-2fixed
sid, trixie13.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openttdsource(unstable)0.6.2-1unimportant

Notes

no vulnerability at all, not exploitable remote or local, openttd

Search for package or bug name: Reporting problems