Information on source package openttd

Available versions

ReleaseVersion
jessie1.4.4-2
stretch1.6.1-1
buster1.8.0-2
bullseye1.9.1-1
sid1.9.1-1

Resolved issues

BugDescription
CVE-2013-6411The HandleCrashedAircraft function in aircraft_cmd.cpp in OpenTTD 0.3. ...
CVE-2012-3436OpenTTD 0.6.0 through 1.2.1 does not properly validate requests to cle ...
CVE-2012-0049
CVE-2011-3343Multiple buffer overflows in OpenTTD before 1.1.3 allow local users to ...
CVE-2011-3342Multiple buffer overflows in OpenTTD before 1.1.3 allow remote attacke ...
CVE-2011-3341Multiple off-by-one errors in order_cmd.cpp in OpenTTD before 1.1.3 al ...
CVE-2010-4168Multiple use-after-free vulnerabilities in OpenTTD 1.0.x before 1.0.5 ...
CVE-2010-2534The NetworkSyncCommandQueue function in network/network_command.cpp in ...
CVE-2010-0406OpenTTD before 1.0.1 allows remote attackers to cause a denial of serv ...
CVE-2010-0402OpenTTD before 1.0.1 does not properly validate index values of certai ...
CVE-2010-0401OpenTTD before 1.0.1 accepts a company password for authentication in ...
CVE-2009-4007Unspecified vulnerability in the NormaliseTrainConsist function in src ...
CVE-2008-3577Buffer overflow in src/openttd.cpp in OpenTTD before 0.6.2 allows loca ...
CVE-2008-3576Buffer overflow in the TruncateString function in src/gfx.cpp in OpenT ...
CVE-2008-3547Buffer overflow in the server in OpenTTD 0.6.1 and earlier allows remo ...

Security announcements

DSA / DLADescription
DSA-2524-1openttd - several
DSA-2386-1openttd - several
DSA-2386-1openttd - several

Search for package or bug name: Reporting problems