CVE-2008-3657

NameCVE-2008-3657
DescriptionThe dl module in Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not check "taintness" of inputs, which allows context-dependent attackers to bypass safe levels and execute dangerous functions by accessing a library using DL.dlopen.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1651-1, DSA-1652-1
NVD severityhigh (attack range: remote)
Debian Bugs494401, 494402
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)squeeze (security), squeeze1.8.7.302-2squeeze2fixed
squeeze (lts)1.8.7.302-2squeeze3fixed
wheezy1.8.7.358-7.1+deb7u1fixed
wheezy (security)1.8.7.358-7.1+deb7u2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)1.8.7.72-1high494401
ruby1.8sourceetch1.8.5-4etch3highDSA-1651-1
ruby1.9source(unstable)1.9.0.2-6high494402
ruby1.9sourceetch1.9.0+20060609-1etch3highDSA-1652-1

Notes

http://www.ruby-lang.org/en/news/2008/08/08/multiple-vulnerabilities-in-ruby/

Search for package or bug name: Reporting problems