CVE-2008-3889

NameCVE-2008-3889
DescriptionPostfix 2.4 before 2.4.9, 2.5 before 2.5.5, and 2.6 before 2.6-20080902, when used with the Linux 2.6 kernel, leaks epoll file descriptors during execution of "non-Postfix" commands, which allows local users to cause a denial of service (application slowdown or exit) via a crafted command, as demonstrated by a command in a .forward file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postfix (PTS)stretch3.1.15-0+deb9u1fixed
buster3.4.14-0+deb10u1fixed
bullseye3.5.6-1fixed
bookworm, sid3.5.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postfixsourceetch(not affected)
postfixsource(unstable)2.5.5-1low

Notes

[etch] - postfix <not-affected> (Vulnerable code not present)
http://www.postfix.org/announcements/20080902.html

Search for package or bug name: Reporting problems