CVE-2008-3905

NameCVE-2008-3905
Descriptionresolv.rb in Ruby 1.8.5 and earlier, 1.8.6 before 1.8.6-p287, 1.8.7 ...
SourceCVE (at NVD; oss-sec, OSVDB, EDB, Red Hat, Ubuntu, Gentoo, SuSE, more)
ReferencesDSA-1651-1, DSA-1652-1
Debian Bugs498977, 498978
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)squeeze1.8.7.302-2squeeze1fixed
squeeze (security)1.8.7.302-2squeeze2fixed
wheezy, wheezy (security)1.8.7.358-7.1+deb7u1fixed
sid1.8.7.358-11fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)1.8.7.72-1498978
ruby1.8sourceetch1.8.5-4etch3DSA-1651-1
ruby1.9source(unstable)1.9.0.2-6498977
ruby1.9sourceetch1.9.0+20060609-1etch3DSA-1652-1

Search for package or bug name: Reporting problems

Home - Testing Security Team - Debian Security - Source (SVN)