CVE-2008-4066

NameCVE-2008-4066
DescriptionMozilla Firefox 2.0.0.14, and other versions before 2.0.0.17, allows remote attackers to bypass cross-site scripting (XSS) protection mechanisms and conduct XSS attacks via HTML-escaped low surrogate characters that are ignored by the HTML parser, as demonstrated by a "jav&#56325ascript" sequence, aka "HTML escaped low surrogates bug."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1649-1, DSA-1669-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
icedove (PTS)squeeze, squeeze (security)3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.7.0-1~deb7u1fixed
jessie31.6.0-1fixed
jessie (security)31.7.0-1~deb8u1fixed
stretch, sid31.7.0-1fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.7.0esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)31.7.0esr-1~deb8u1fixed
stretch38.0.1-1fixed
sid38.0.1-5fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.12-1medium
iceapesourceetch(unfixed)end-of-life
icedovesource(unstable)2.0.0.17-1medium
iceweaselsource(unstable)3.0.1-1medium
iceweaselsourceetch2.0.0.17-0etch1mediumDSA-1649-1
xulrunnersource(unstable)1.9.0.1-1medium
xulrunnersourceetch1.8.0.15~pre080614h-0etch1mediumDSA-1669-1

Notes

[etch] - iceape <end-of-life> (Etch Packages no longer covered by security support)

Search for package or bug name: Reporting problems