CVE-2008-4316

NameCVE-2008-4316
DescriptionMultiple integer overflows in glib/gbase64.c in GLib before 2.20 allow context-dependent attackers to execute arbitrary code via a long string that is converted either (1) from or (2) to a base64 representation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1747-1
Debian Bugs520046

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glib2.0 (PTS)buster2.58.3-2+deb10u3fixed
buster (security)2.58.3-2+deb10u5fixed
bullseye2.66.8-1+deb11u1fixed
bookworm2.74.6-2fixed
trixie2.78.4-1fixed
sid2.78.4-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glib2.0sourceetch2.12.4-2+etch1DSA-1747-1
glib2.0sourcelenny2.16.6-1+lenny1DSA-1747-1
glib2.0source(unstable)2.20.0-1medium520046

Search for package or bug name: Reporting problems