CVE-2008-4456

NameCVE-2008-4456
DescriptionCross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document. NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1783-1
NVD severitylow (attack range: remote)
Debian Bugs526254

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-dfsg-5.0source(unstable)5.0.51-1low526254
mysql-dfsg-5.0sourceetch5.0.32-7etch10lowDSA-1783-1
mysql-dfsg-5.0sourcelenny5.0.51a-24+lenny1lowDSA-1783-1

Search for package or bug name: Reporting problems