CVE-2008-5023

NameCVE-2008-5023
DescriptionFirefox 3.x before 3.0.4, Firefox 2.x before 2.0.0.18, and SeaMonkey 1.x before 1.1.13 allows remote attackers to bypass the protection mechanism for codebase principals and execute arbitrary script via the -moz-binding CSS property in a signed JAR file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1669-1, DSA-1671-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.7.0esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)31.7.0esr-1~deb8u1fixed
stretch38.0.1-1fixed
sid38.0.1-5fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.13-1high
iceapesourceetch(unfixed)end-of-life
iceweaselsource(unstable)3.0.4-1high
iceweaselsourceetch2.0.0.18-0etch1highDSA-1671-1
xulrunnersource(unstable)1.9.0.4-1high
xulrunnersourceetch1.8.0.15~pre080614h-0etch1highDSA-1669-1

Notes

[etch] - iceape <end-of-life> (Etch Packages no longer covered by security support)

Search for package or bug name: Reporting problems