CVE-2008-5185

NameCVE-2008-5185
DescriptionThe highlighting functionality in geshi.php in GeSHi before 1.0.8 allows remote attackers to cause a denial of service (infinite loop) via an XML sequence containing an opening delimiter without a closing delimiter, as demonstrated using "<".
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-179-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
geshi (PTS)jessie1.0.8.11-2fixed
stretch1.0.8.11-2.1fixed
bullseye, sid, buster1.0.8.11-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
geshisource(unstable)1.0.8.1-1medium
geshisourcelenny1.0.7.22-1+lenny1DTSA-179-1

Search for package or bug name: Reporting problems