CVE-2008-5512

NameCVE-2008-5512
DescriptionMultiple unspecified vulnerabilities in Mozilla Firefox 3.x before 3.0.5 and 2.x before 2.0.0.19, Thunderbird 2.x before 2.0.0.19, and SeaMonkey 1.x before 1.1.14 allow remote attackers to run arbitrary JavaScript with chrome privileges via unknown vectors in which "page content can pollute XPCNativeWrappers."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1696-1, DSA-1697-1, DSA-1704-1, DSA-1707-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
icedove (PTS)squeeze, squeeze (security)3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.7.0-1~deb7u1fixed
stretch, jessie31.6.0-1fixed
jessie (security)31.7.0-1~deb8u1fixed
sid31.7.0-1fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.7.0esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)31.7.0esr-1~deb8u1fixed
stretch, sid38.0.1-1fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.14-1medium
iceapesourceetch1.0.13~pre080614i-0etch1mediumDSA-1697-1
icedovesource(unstable)2.0.0.19-1medium
icedovesourceetch1.5.0.13+1.5.0.15b.dfsg1+prepatch080614i-0etch1mediumDSA-1696-1
iceweaselsource(unstable)3.0.5-1medium
iceweaselsourceetch2.0.0.19-0etch1mediumDSA-1707-1
xulrunnersource(unstable)1.9.0.5-1medium
xulrunnersourceetch1.8.0.15~pre080614i-0etch1mediumDSA-1704-1

Search for package or bug name: Reporting problems