CVE-2009-0318

NameCVE-2009-0318
DescriptionUntrusted search path vulnerability in the GObject Python interpreter wrapper in Gnumeric allows local users to execute arbitrary code via a Trojan horse Python file in the current working directory, related to a vulnerability in the PySys_SetArgv function (CVE-2008-5983).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-190-1
NVD severitymedium
Debian Bugs513418

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnumeric (PTS)jessie1.12.18-2fixed
stretch1.12.32-1fixed
buster1.12.44-1fixed
bullseye, sid1.12.46-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnumericsource(unstable)1.8.4-3low513418
gnumericsourceetch1.6.3-5.1+etch2
gnumericsourcelenny1.8.3-5+lenny1DTSA-190-1

Search for package or bug name: Reporting problems