CVE-2009-0360

NameCVE-2009-0360
DescriptionRuss Allbery pam-krb5 before 3.13, when linked against MIT Kerberos, does not properly initialize the Kerberos libraries for setuid use, which allows local users to gain privileges by pointing an environment variable to a modified Kerberos configuration file, and then launching a PAM-based setuid application.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1721-1
NVD severitymedium (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpam-krb5 (PTS)squeeze4.3-1fixed
wheezy4.6-1fixed
jessie, sid4.6-3fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpam-krb5source(unstable)3.13-2medium
libpam-krb5sourceetch2.6-1etch1mediumDSA-1721-1
libpam-krb5sourcelenny3.11-4medium

Search for package or bug name: Reporting problems