CVE-2009-0361

NameCVE-2009-0361
DescriptionRuss Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other software, does not properly handle calls to pam_setcred when running setuid, which allows local users to overwrite and change the ownership of arbitrary files by setting the KRB5CCNAME environment variable, and then launching a setuid application that performs certain pam_setcred operations.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1721-1, DSA-1722-1
NVD severitymedium (attack range: local)
Debian Bugs516695
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpam-krb5 (PTS)squeeze4.3-1fixed
wheezy4.6-1fixed
jessie4.6-3fixed
stretch, sid4.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpam-heimdalsource(unstable)3.10-2.1medium516695
libpam-heimdalsourceetch2.5-1etch1mediumDSA-1722-1
libpam-krb5source(unstable)3.13-2medium
libpam-krb5sourceetch2.6-1etch1mediumDSA-1721-1
libpam-krb5sourcelenny3.11-4medium

Search for package or bug name: Reporting problems