CVE-2009-0583

NameCVE-2009-0583
DescriptionMultiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1746-1, DTSA-198-1
NVD severityhigh (attack range: remote, user-initiated)
Debian Bugs522416, 522448
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
argyll (PTS)squeeze1.1.1-1fixed
wheezy1.4.0-8fixed
jessie1.6.3-4fixed
stretch, sid1.7.0+repack-4fixed
ghostscript (PTS)squeeze, squeeze (security)8.71~dfsg2-9+squeeze1fixed
squeeze (lts)8.71~dfsg2-9+squeeze2fixed
wheezy9.05~dfsg-6.3+deb7u1fixed
jessie, stretch9.06~dfsg-2fixed
sid9.15~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
argyllsource(unstable)1.0.3-2high522448
ghostscriptsource(unstable)8.64~dfsg-1.1medium522416
ghostscriptsourcelenny8.62.dfsg.1-3.2lenny1highDSA-1746-1
ghostscriptsourcesqueeze8.64~dfsg-1+squeeze1highDTSA-198-1
gs-espsource(unstable)(unfixed)high
gs-gplsource(unstable)(unfixed)medium
gs-gplsourceetch8.54.dfsg.1-5etch2highDSA-1746-1

Search for package or bug name: Reporting problems