CVE-2009-0584

NameCVE-2009-0584
Descriptionicc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code by using a device file for processing a crafted image file associated with large integer values for certain sizes, related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1746-1, DTSA-198-1
NVD severityhigh
Debian Bugs522416, 522448

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
argyll (PTS)stretch1.9.2+repack-1fixed
buster2.0.1+repack-1fixed
bullseye2.0.1+repack-1.1fixed
bookworm, sid2.2.0+repack-1fixed
ghostscript (PTS)stretch9.26a~dfsg-0+deb9u6fixed
stretch (security)9.26a~dfsg-0+deb9u7fixed
buster, buster (security)9.27~dfsg-2+deb10u4fixed
bullseye (security), bullseye9.53.3~dfsg-7+deb11u1fixed
bookworm, sid9.54.0~dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
argyllsource(unstable)1.0.3-2522448
ghostscriptsourcelenny8.62.dfsg.1-3.2lenny1DSA-1746-1
ghostscriptsourcesqueeze8.64~dfsg-1+squeeze1DTSA-198-1
ghostscriptsource(unstable)8.64~dfsg-1.1medium522416
gs-espsource(unstable)(unfixed)
gs-gplsourceetch8.54.dfsg.1-5etch2DSA-1746-1
gs-gplsource(unstable)(unfixed)medium

Search for package or bug name: Reporting problems