DescriptionArray index error in the (1) dtoa implementation in dtoa.c (aka pdtoa.c) and the (2) gdtoa (aka new dtoa) implementation in gdtoa/misc.c in libc, as used in multiple operating systems and products including in FreeBSD 6.4 and 7.2, NetBSD 5.0, OpenBSD 4.5, Mozilla Firefox 3.0.x before 3.0.15 and 3.5.x before 3.5.4, K-Meleon 1.5.3, SeaMonkey 1.1.8, and other products, allows context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a large precision value in the format argument to a printf function, which triggers incorrect memory allocation and a heap-based buffer overflow during conversion to a floating-point number.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1931-1, DSA-1998-1
NVD severitymedium (attack range: remote)
Debian Bugs559265, 559266
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)squeeze4:4.4.5-2+squeeze3fixed
squeeze (lts)4:4.4.5-2+squeeze4fixed
wheezy, wheezy (security)4:4.8.4-4+deb7u1fixed
stretch, sid, jessie4:4.14.2-5fixed
kdelibs (PTS)squeeze4:3.5.10.dfsg.1-5fixed
nspr (PTS)squeeze, squeeze (security)4.8.6-1+squeeze1fixed
squeeze (lts)4.8.6-1+squeeze2fixed
wheezy, wheezy (security)2:4.9.2-1+deb7u2fixed
stretch, sid2:4.10.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[etch] - nspr <end-of-life> (Mozilla packages from oldstable no longer covered by security support)
[lenny] - kde4libs <no-dsa> (Only uses by a few packages in Lenny, hardly any attack vector)

Search for package or bug name: Reporting problems