CVE-2009-0689

NameCVE-2009-0689
DescriptionArray index error in the (1) dtoa implementation in dtoa.c (aka pdtoa.c) and the (2) gdtoa (aka new dtoa) implementation in gdtoa/misc.c in libc, as used in multiple operating systems and products including in FreeBSD 6.4 and 7.2, NetBSD 5.0, OpenBSD 4.5, Mozilla Firefox 3.0.x before 3.0.15 and 3.5.x before 3.5.4, K-Meleon 1.5.3, SeaMonkey 1.1.8, and other products, allows context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a large precision value in the format argument to a printf function, which triggers incorrect memory allocation and a heap-based buffer overflow during conversion to a floating-point number.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, web search, more)
ReferencesDLA-376-1, DSA-1931-1, DSA-1998-1
NVD severitymedium (attack range: remote)
Debian Bugs559265, 559266
Debian/oldoldstablepackage mono is vulnerable.
Debian/oldstablepackage mono is vulnerable.
Debian/stablepackage mono is vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)squeeze4:4.4.5-2+squeeze3fixed
squeeze (lts)4:4.4.5-2+squeeze4fixed
wheezy, wheezy (security)4:4.8.4-4+deb7u1fixed
jessie4:4.14.2-5fixed
stretch, sid4:4.14.14-1fixed
kdelibs (PTS)squeeze4:3.5.10.dfsg.1-5fixed
squeeze (lts)4:3.5.10.dfsg.1-5+deb6u1fixed
mono (PTS)squeeze, squeeze (security)2.6.7-5.1vulnerable
squeeze (lts)2.6.7-5.1+deb6u2fixed
wheezy, wheezy (security)2.10.8.1-8+deb7u1vulnerable
jessie3.2.8+dfsg-10vulnerable
stretch, sid4.2.1.102+dfsg2-5fixed
nspr (PTS)squeeze, squeeze (security)4.8.6-1+squeeze1fixed
squeeze (lts)4.8.6-1+squeeze3fixed
wheezy2:4.9.2-1+deb7u2fixed
wheezy (security)2:4.9.2-1+deb7u3fixed
jessie, jessie (security)2:4.10.7-1+deb8u1fixed
stretch, sid2:4.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)4:4.3.4-1medium559266
kdelibssource(unstable)4:3.5.10.dfsg.1-3medium559265
kdelibssourcelenny4:3.5.10.dfsg.1-0lenny4mediumDSA-1998-1
monosource(unstable)4.2.1.102+dfsg2-4medium
monosourcesqueeze2.6.7-5.1+deb6u2mediumDLA-376-1
nsprsource(unstable)4.8-2medium
nsprsourceetch(unfixed)end-of-life
nsprsourcelenny4.7.1-5mediumDSA-1931-1

Notes

[etch] - nspr <end-of-life> (Mozilla packages from oldstable no longer covered by security support)
[lenny] - kde4libs <no-dsa> (Only uses by a few packages in Lenny, hardly any attack vector)
http://www.mono-project.com/docs/about-mono/vulnerabilities/
https://gist.github.com/directhex/01e853567fd2cc74ed39

Search for package or bug name: Reporting problems