CVE-2009-0774

NameCVE-2009-0774
DescriptionThe layout engine in Mozilla Firefox 2 and 3 before 3.0.7, Thunderbird before 2.0.0.21, and SeaMonkey 1.1.15 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to gczeal, a different vulnerability than CVE-2009-0773.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1751-1, DSA-1830-1
NVD severityhigh (attack range: remote)
Debian Bugs535124

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:45.2.0-2~deb7u1fixed
jessie38.8.0-1~deb8u1fixed
jessie (security)1:45.2.0-1~deb8u1fixed
stretch, sid1:45.2.0-4fixed
iceweasel (PTS)wheezy (security), wheezy38.8.0esr-1~deb7u1fixed
jessie (security), jessie38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)2.0.0.22-1high535124
icedovesourcelenny2.0.0.22-0lenny1highDSA-1830-1
icedovesourcesqueeze2.0.0.22-0lenny1high
iceweaselsource(unstable)3.0high
iceweaselsourceetch(unfixed)end-of-life
xulrunnersource(unstable)1.9.0.7-1high
xulrunnersourceetch(unfixed)end-of-life
xulrunnersourcelenny1.9.0.7-0lenny1highDSA-1751-1

Notes

[etch] - iceweasel <end-of-life> (Etch Packages no longer covered by security support)
Iceweasel in Lenny links against Xulrunner
[etch] - xulrunner <end-of-life> (Etch Packages no longer covered by security support)

Search for package or bug name: Reporting problems