CVE-2009-0784

NameCVE-2009-0784
DescriptionRace condition in the SystemTap stap tool 0.0.20080705 and 0.0.20090314 allows local users in the stapusr group to insert arbitrary SystemTap kernel modules and gain privileges via unknown vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1755-1
NVD severitymedium (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
systemtap (PTS)squeeze (security), squeeze1.2-5+squeeze1fixed
wheezy1.7-1+deb7u1fixed
jessie, sid2.6-0.2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
systemtapsource(unstable)0.0.20090314-2medium
systemtapsourceetch(not affected)
systemtapsourcelenny0.0.20080705-1+lenny1mediumDSA-1755-1

Notes

[etch] - systemtap <not-affected> (vulnerable code not present)

Search for package or bug name: Reporting problems