Information on source package systemtap

Available versions

ReleaseVersion
stretch3.1-2
buster4.0-1
bullseye4.3-2
sid4.3-2

Resolved issues

BugDescription
CVE-2012-0875SystemTap 1.7, 1.6.7, and probably other versions, when unprivileged m ...
CVE-2011-2503The insert_module function in runtime/staprun/staprun_funcs.c in the s ...
CVE-2011-2502runtime/staprun/staprun_funcs.c in the systemtap runtime tool (staprun ...
CVE-2011-1781SystemTap 1.4, when unprivileged (aka stapusr) mode is enabled, allows ...
CVE-2011-1769SystemTap 1.4 and earlier, when unprivileged (aka stapusr) mode is ena ...
CVE-2010-4171The staprun runtime tool in SystemTap 1.3 does not verify that a modul ...
CVE-2010-4170The staprun runtime tool in SystemTap 1.3 does not properly clear the ...
CVE-2010-0412stap-server in SystemTap 1.1 does not properly restrict the value of t ...
CVE-2010-0411Multiple integer signedness errors in the (1) __get_argv and (2) __get ...
CVE-2009-4273stap-server in SystemTap before 1.1 allows remote attackers to execute ...
CVE-2009-2911SystemTap 1.0, when the --unprivileged option is used, does not proper ...
CVE-2009-0784Race condition in the SystemTap stap tool 0.0.20080705 and 0.0.2009031 ...

Security announcements

DSA / DLADescription
DSA-2348-1systemtap - several
DSA-1755-1systemtap - local privilege escalation

Search for package or bug name: Reporting problems