CVE-2009-0792

NameCVE-2009-0792
DescriptionMultiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images. NOTE: this issue exists because of an incomplete fix for CVE-2009-0583.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2080-1, DTSA-198-1
NVD severityhigh (attack range: remote)
Debian Bugs523472, 524802, 524915, 561717

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
argyll (PTS)wheezy1.4.0-8fixed
jessie1.6.3-4fixed
stretch1.9.2+repack-1fixed
buster, sid2.0.0+repack-1fixed
ghostscript (PTS)wheezy9.05~dfsg-6.3+deb7u2fixed
wheezy (security)9.05~dfsg-6.3+deb7u7fixed
jessie (security), jessie9.06~dfsg-2+deb8u6fixed
stretch (security), stretch9.20~dfsg-3.2+deb9u1fixed
buster, sid9.22~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
argyllsource(unstable)1.0.3-3medium523472, 524802
ghostscriptsource(unstable)8.64~dfsg-1.1medium524915
ghostscriptsourcelenny8.62.dfsg.1-3.2lenny4highDSA-2080-1
ghostscriptsourcesqueeze8.64~dfsg-1+squeeze1highDTSA-198-1
gs-gplsource(unstable)(unfixed)medium561717

Search for package or bug name: Reporting problems