CVE-2009-0796

NameCVE-2009-0796
DescriptionCross-site scripting (XSS) vulnerability in Status.pm in Apache::Status and Apache2::Status in mod_perl1 and mod_perl2 for the Apache HTTP Server, when /perl-status is accessible, allows remote attackers to inject arbitrary web script or HTML via the URI.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs567635

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache2-mod-perl2 (PTS)stretch2.0.10-2+deb9u1fixed
buster2.0.10-3fixed
bullseye2.0.11-4fixed
bookworm, sid2.0.11-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apachesource(unstable)(unfixed)
libapache2-mod-perl2sourcelenny2.0.4-5+lenny1
libapache2-mod-perl2source(unstable)2.0.4-6low567635

Notes

[etch] - apache <no-dsa> (minor issue)

Search for package or bug name: Reporting problems