CVE-2009-1305

NameCVE-2009-1305
DescriptionThe JavaScript engine in Mozilla Firefox before 3.0.9, Thunderbird before 2.0.0.22, and SeaMonkey before 1.1.16 allows remote attackers to cause a denial of service (application crash) and possibly trigger memory corruption via vectors involving JSOP_DEFVAR and properties that lack the JSPROP_PERMANENT attribute.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1797-1
NVD severitymedium (attack range: remote)
Debian/oldstablepackage kompozer is vulnerable; however, the security impact is unimportant.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kompozer (PTS)squeeze1:0.8~b3.dfsg.1-0.1vulnerable
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kompozersource(unstable)(unfixed)unimportant
xulrunnersource(unstable)1.9.0.9-1medium
xulrunnersourceetch(unfixed)end-of-life
xulrunnersourcelenny1.9.0.9-0lenny2mediumDSA-1797-1

Notes

[etch] - xulrunner <end-of-life> (Etch Packages no longer covered by security support)
kompozer shares the browser engine with Firefox, but JavaScript is not enabled

Search for package or bug name: Reporting problems